Visioneer Knowledgebase
Visioneer Knowledgebase
Title: Compatibility Mode Check Tool
Article ID: VIS1030
Updated: 8/7/2006
Operating Systems: Windows XP / 2000 / Me / 98
Scanner Models: Visioneer Flatbed: 9520, 9420, 7400, 9320, 9220, 9120, 9020, 9000, 8900, 8800, 8700, 8600, 8100, 7700, 7600, 7300, 7100, 6600, 6400, 7600, 6200, 6100, 6000, 5800, 5600, 5300, 4800, 4500, 4400, 3300, 3100, 3000, PaperPort OneTouch
  Visioneer SheetFed: XP300, XP220, XP200, XP100, RoadWarrior (RW120, PRW120), StrobePro, PaperPort Strobe, PaperPort IX, VX, MX
  Visioneer ADF: PT480, XP470, XP450, PT430, S500 , PT680, PT780, 9750, 9650, 9450, 8650
  Xerox Flatbed: X6400, X7600, X4800, X2400
  Xerox SheetFed: TS100, CS200
  Xerox ADF: DM250, DM250L, DM252, DM262, DM262i, DM272, DM150, DM152, DM162, DM510, DM515, DM520, DM632, DM3640, DM752
 
Symptom:
 
PaperPort fails to load one or more of its components; for instance, the PaperPort link bar fails to load up the application link icons or gives a PPLINKSBR.OCX or PPLINKS error. You get a Simple Search error referencing SSINDEXER when opening PaperPort. Your scanner does not appear in PaperPort. You are getting a maxlink.ini or maxlink3.dll error message when opening PaperPort, etc...
 
Cause:
 
These error messages usually only occur on Windows 2000 or Windows XP because one or more of the PaperPort or Scanner Driver files are set to run in Compatibility Mode for Windows 95, 98 or NT, thereby preventing the PaperPort software from loading all of its components in a Windows 2000 or Windows XP environment.
 
Solution:
 
The Compatibility_Check tool is designed to make it easy to check your system for any of the default Windows compatibility modes that may be applied to application.
 
  1. Click here and download Compatibility_Check.exe to your Windows desktop
  2. Double-click Compatibility_Check.exe on your desktop to run it
  3. Compatibility Check will open and give a list of applications running in compatibility mode
  4. For each entry that has 'ScanSoft' or 'Visioneer' in it, select it then click 'Remove Compatibility Mode'
  5. Close Compatibility Check and Restart you computer
  6. Everything should be functioning normally now
  7. If you continue to experience error, reinstall the software
If you receive an error "The Application Failed to Initialize Properly (0xc0000135)" , this means you do not have .NET version 1.1 or higher installed. You can either click here and install .NET 1.1 or use the instructions below.


If you were unable to use the tool above, follow these directions:
  1. Download and run Compatibility_Check_No.NET.
  2. When the tool runs, a window will automatically open with the listing of what has been detected. If the window says "No applications detected as running in compatibility mode" then compatibility modes are not applied and you may need to reinstall your software.
    1. If the window that opens shows you names of programs, then that means those programs are running in special "Compatibility Modes" that changes how Windows treats these programs. For best performance your scanner software should not be run in compatibility mode.
  3. If applications are detected that are running in compatibility mode, you will see a second program on your desktop called "Compatibility_Jump". Running this tool opens the Registry Editor in the exact spot that your Compatibility settings are stored. If you have never used the Registry Editor before, please contact your support personnel for general safety procedures concerning the registry.
    1. On the right-hand window pane you will see the names and locations of your programs. To remove the compatibility modes, right-click on the name of your program and select "Delete". Once all the affected applications are removed from the list, restart your computer.
  4. Your applications should function normally at this point. If they do not, you may need to reinstall.
 
Library:
 
VIS1000 - Performing a Quick Uninstall Windows 2000 or XP
VIS1009 - Performing a Quick Uninstall Windows 98 or Me

 

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Visioneer provides these technical articles for information use only. The information is generally for a specific scanner model distributed by Visioneer and a designated version of software provided with the scanner. Visioneer makes reasonable efforts to verify the accuracy of content and issue resolution in these technical articles but cannot guarantee any matter including accuracy or results. The articles are provided "as is", without representation or warranty, express or implied, whether of merchantability, fitness for particular purpose, title, or non-infringement. Visioneer disclaims any liability for damages, whether direct or indirect, special, incidental, or consequential, from use of the information in these articles. Visioneer does not evaluate any effect on software and hardware not provided by Visioneer, and therefore disclaims any liability for same. Visioneer is not responsible for the content of support pages accessed through external links. The articles are subject to revision or change without notice.