Visioneer Knowledgebase
Visioneer Knowledgebase
Title: General USB Communication
Article ID: VIS1057
Updated: 8/8/2006
Operating Systems: Windows XP / 2000 / Me / 98
Scanner Models: Visioneer Flatbed: 9520, 9420, 7400, 9320, 9220, 9120, 9020, 9000, 8900, 8800, 8700, 8600, 8100, 7700, 7600, 7300, 7100, 6600, 6400, 7600, 6200, 6100, 6000, 5800, 5600, 5300, 4800, 4500, 4400, 3300, 3100, 3000, PaperPort OneTouch
  Visioneer SheetFed: XP300, XP220, XP200, XP100, RoadWarrior (RW120, PRW120), StrobePro, PaperPort Strobe, PaperPort IX, VX, MX
  Visioneer ADF: PT480, XP470, XP450, PT430, S500 , PT680, PT780, 9750, 9650, 9450, 8650
  Xerox Flatbed: X6400, X7600, X4800, X2400
  Xerox SheetFed: TS100, CS200
  Xerox ADF: DM250, DM250L, DM252, DM262, DM262i, DM272, DM150, DM152, DM162, DM510, DM515, DM520, DM632, DM3640, DM752
 
Symptom:
 
On some systems, the installation process appears to go smoothly, yet the message "Scanner not found" or "Error communicating with TWAIN device" appears.
 
Cause:
 
There are 3 main reasons for communication errors:
  1. The device was plugged into the USB port prior to installation of the driver.
    When the Operating System is not able to match a driver for the device, it is registered as an UNKNOWN hardware device in the registry. From that point forward, Windows continues to "ignore" the device even after the driver does load. Thus the software still can not find the scanner.
  2. The power cable is not correct for the scanner, or the USB cable length exceeds the recommended maximum of 6'. This may impact the ability of the device to maintain communication across the link.
  3. There may be incompatibilities with the PC hardware, specifically the USB chipset.
 
Solution:
 
Check your connections:
  1. Shut down the computer and confirm that you are using the power cable that came with the scanner.
  2. Remove any USB hubs and ensure the USB cable does not exceed 6' between the scanner and the computer.
  3. Unplug all USB devices, re-start the computer and connect only the scanner to eliminate any potential conflicts.
  4. Shut down and change USB ports, as most computers are sold with 2 or 4 USB ports. If you installed a PCI USB card for additional ports, use the ports that were originally installed on the system.
  5. Confirm that you selected the correct scanning hardware during the installation of the software and that the correct scanner is selected in the application you are trying to scan from.
  6. Verify that the PaperPort Program is installed to the drive that has the Windows directory (usually the C:\ drive).
 
Check your chipset:

There are some USB chipsets that have a high number of complaints over compatibility with certain USB devices like scanners. Any systems with the SIS 7001, VIA Rev. 5 or later, or open HCD chipsets may experience communication problems. There may be patches available to help resolve some of these problems.

To check your Universal Host Controller chipset:
  1. Click "Start" then "Run" and type "Devmgmt.msc" and click "OK" to get to the "Device Manager".
  2. Scroll down through the list of items until you see "Universal serial bus controller". Double click it. This will show the items associated to the USB controller.
  3. Listed under "Universal serial bus controller" should be the manufacturer of the controller.
  4. If your computer uses a VIA controller and is running Windows 98 Second Edition, click here for the Microsoft patch information.
  5. If your USB controller is listed as a SIS 7001, VIA Rev. 5 or later, or Open HCD the scanner may not function correctly. Contact your PC manufacturer for any available system patches.
 
Check your driver:

The driver that Windows installed for use with the scanner may not have installed properly. Follow the steps below to redetect the scanner:

Windows ME and 98 users
  1. Right-click on the "My Computer" icon on your Windows Desktop
  2. Select "Properties" from the list
  3. Click on the "Device Manager" tab
  4. Find "Imaging Devices" and click on the plus (+) next to it to expand the list
  5. Select your scanner, then click on the "Remove" button
  6. IF you see "?Other Devices", click on the plus (+) next to it to expand the list
  7. Select your scanner then click on the "Remove"; button – your scanner may be listed as any of the following:
    • USB Scanner
    • USB Device
    • Unknown Device
    • 1200dpi Scanner
    • (your scanner model)
  8. Close the Device Manager
  9. Unplug the scanner from the computer and from the power
  10. Plug the scanner back in to the computer and power
Windows Vista, XP, and 2000 users
  1. Disconnect the power and USB cable from the scanner.
  2. Click here and select "Run" or "Open".
  3. The Windows Device Manager will open.
    • Click on the "View" menu then select "Show hidden devices".
  4. Click the "+" next to "Imaging Devices". This will show all Imaging Devices previously and currently connected to the computer.
  5. Right-click on the Visioneer or Xerox scanner name and left click on "Uninstall".
  6. If the scanner is listed more than one time, uninstall ALL occurrences of the scanner.
  7. IF you see "?Other Devices" in the device manager list, click on the "+" to view the list of Other Devices.
  8. Right click then left click on "Uninstall" for each occurrence of the scanner. The scanner may be listed as any of the following:
    • USB Scanner
    • USB Device
    • Unknown Device
    • 1200 DPI Scanner
    • (Your Scanner Model)
    • (any other scanners or cameras listed here that you no longer use)
  9. Click the "+" next to "Universal Serial Bus Controllers".
  10. Right-click every listing of "Unknown Device" and select uninstall.
  11. Once all instances have been removed from device manager, reconnect the power and USB.
If after redetecting the scanner is listed under "Other Devices", click VIS1163 - Scanner Listed Under Other Devices for steps to resolve this issue.

 

Visioneer Disclaimer


Visioneer provides these technical articles for information use only. The information is generally for a specific scanner model distributed by Visioneer and a designated version of software provided with the scanner. Visioneer makes reasonable efforts to verify the accuracy of content and issue resolution in these technical articles but cannot guarantee any matter including accuracy or results. The articles are provided "as is", without representation or warranty, express or implied, whether of merchantability, fitness for particular purpose, title, or non-infringement. Visioneer disclaims any liability for damages, whether direct or indirect, special, incidental, or consequential, from use of the information in these articles. Visioneer does not evaluate any effect on software and hardware not provided by Visioneer, and therefore disclaims any liability for same. Visioneer is not responsible for the content of support pages accessed through external links. The articles are subject to revision or change without notice.