Visioneer Knowledgebase
Visioneer Knowledgebase
Title: ReInstalling Your Scanner Driver on Windows 7 or Vista
Article ID:VIS1382
Updated:9/13/2013
Operating Systems:Please check below for driver compatibility
Scanner Models: Visioneer:
Flatbed: 9520, 9420, 7400, 7300, 9320, 9220, 9120, 9020, 9000, 8920, 8900, 8820, 8800, 8700, 8600, 8100, 7710, 7700, 7600, 7100, 6600, 6400u, 6200, 6100, 6000, 5820, 5800, 5600, 5300, 4800u, 4500, 4400, 3300, 3100, 3000, OneTouch, 2400p, 2400u, 2600u, 6136, 6142
ADF: XP470, XP450, PT430, PT470, 9750, 9650, 9650i, 9450, 8650, PT680, PT780
Strobe: 400, 500, XP300, XP220, XP200, XP100, RoadWarrior (RW120, PRW120)
Mobility
 Xerox:
X7600, X6400, DM250, DM250L, DM252, DM262, DM262i, DM272, DM150, DM152, DM162, DM510, DM515, DM520, DM632, DM700, DM752, DM3115, DM3220, DM4440, DM5445, DM5460, DM4830, DM4790, DM4799, DM4700, XMS
 
Symptom:
 
Your scanner does not appear to be functioning normally; you are getting errors when attempting to scan, your images are not easily readable, or you are unable to access the scanner properties.
 
Cause:
 
Problems may arise after you have made changes to your Windows environment (e.g. you installed Windows Updates, you installed another scanning application, etc...).
 
Solution:
 

Reinstall the scanner driver which will recalibrate and will remove any corrupted driver files which may be causing the issue.

When using this article, {Scanner Model} is used to indicate your scanner's model, items in Bold indicate words to look for on your screen, items in "Quotes" indicate buttons or menu items, and items in Italics indicate things you will type.

 

Section I: Download your scanner driver

    Very Important:

    Before downloading, verify that your scanner's driver is supported by your computer's operating system.
  1. Use the appropriate link to access the support page for your scanner.
  2. Once on your scanner's support page, click on the Driver for your desired language.
  3. Do not "Run" the driver from this page; rather "Save" the driver to your Windows Desktop.
  4. If it is available, also "Save" the OneTouch to your Windows Desktop, using the above instructions.
 

Section II: Download the Remover Utilities listed below to your Windows Desktop for easy access


Follow these instructions to download each of the utilities listed below:
  1. Click on each utility's link, listed below.
  2. Do not "Run" these utilities at this time; rather "Save" them to your Windows Desktop.
  3. Once you have finished downloading each of these utilities, print these directions and close all other open windows so you are looking at your Windows desktop.
Utilities
      Hidden Devices
      INF Clear
      Temp File Remover
If you have not already done so, follow these instructions to download each of the utilities listed below:
  1. In the address bar of your web browser, type the address of each URL below and press "Enter".
  2. Do not "Run" these utilities at this time; rather "Save" them to your Windows Desktop.
  3. When you have finished downloading each of these utilities, close all other open windows so you are looking at your Windows desktop.
    •      Utilities
            INFClear: http://support.visioneer.com/utilities/vista/INFclear.exe
            Hidden Devices: http://support.visioneer.com/utilities/HiddenDevices.exe
            Temp File Remover: http://support.visioneer.com/utilities/Vista/Temp_File_Remover_V.exe
 

Section III: Uninstall the current scanner driver

Before continuing, disconnect the USB and/or power cables from the back of your scanner.
  1. Click on your "Start" menu, and type AppWiz.CPL into the start search box.
  2. When you press "Enter" the Control Panel will open "Programs and Features".
  3. Locate and remove any versions of the scanner's Driver and OneTouch.
    • Your Driver and OneTouch might be listed as any of the following:
      • OneTouch 4.6
      • OneTouch 4.5
      • OneTouch 4.0
      • Xerox {Scanner Model} Driver
      • Visioneer { Scanner Model} Driver

    • Control Panel
  4. Once removal is complete, close all open windows and return to your Windows Desktop.
 

Section IV: Run the utilities you downloaded in Step II


Utility #1: Hidden Devices

  1. On your Windows Desktop, right-click on the Hidden Devices utility and select "Run as Administrator".
  2. The Windows Device Manager will open.
  3. Go to the "View" menu and select "Show Hidden Devices".
  4. Expand Imaging Devices to show all scanners and cameras previously and currently connected to the computer.
  5. Right-click on the Visioneer or Xerox scanner name and select "Uninstall".
  6. In the Confirm Device Uninstall window click on "Delete the driver software for this device" then click on "OK".
    • Repeat steps 5 and 6 for all instances of your scanner .
  7. IF you see ?OtherDevices, expand it.
  8. Right click and "Uninstall" any of the following:
    • USB Scanner
    • USB Device
    • Unknown Device
    • 1200 DPI Scanner
    • {Scanner Model}
    • (any other scanners or cameras listed here that you no longer use)
  9. Close the Device Manager, and return to your Windows Desktop.
Utility #2: INFclear
  1. On your Windows Desktop, right-click on INFClear and select "Run as Administrator".
  2. A black DOS window will open as the utility automatically removes the appropriate files.
  3. Once the DOS window closes you should automatically be returned to your Windows Desktop.
Utility #3: Temp_File_Remover_V
  1. On your Windows Desktop, right-click on Temp_File_Remover_V and select "Run as Administrator".
    • Note: This utility will launch the standard Microsoft Disk Cleanup window. It will close automatically when it is finished.
    • DiskCleanup
  2. After the Temp_File_Remover_V utility closes you should automatically be returned to your Windows Desktop.
  3. Reboot (restart) your computer and proceed to Section V.
 
Section V: Reinstall the scanner driver
  1. Disable any AntiVirus, AntiSpyware, Firewall, PopUp Blocker, Spam Blocker, or Weather Bug software program from running.
  2. You many need to disable UAC for the install to complete. For instructions click here.
  3. You many need to disable UAC for the install to complete. For instructions, search the knowledgebase for VIS1491 - Enabling or Disabling UAC (User Access Control)
    • It is recommended that you re-enable UAC once the installation has completed.
  4. If any of these applications are running, their icons will be in the Windows Notification area on the lower-right side of the computer next to the Windows System Clock.
  5. Right click on each of these icons and choose "Close", "Disable" or "Exit" depending on which option is available to you.
  6. On your Windows Desktop, locate and run the Driver that you downloaded in Section I .
    • Driver Icon
  7. The installation wizard will launch.
  8. Follow the prompts through installing the scanner driver.
  9. STOP when you get to the "Finish / Connect the Scanner" screen.
  10. Plug the scanner into the computer and power to the wall then wait 30 seconds for the system to detect the scanner, then click on the "OK" button.
  11. Repeat steps 6-10 for OneTouch if you downloaded that separately in Section I above.
 
You have now completed the driver installation. If you are prompted to restart the computer please do so. If you have installed OneTouch, you will see a scanner icon in the Windows Notification Area by the system clock.

 

Visioneer Disclaimer


Visioneer provides these technical articles for information use only. The information is generally for a specific scanner model distributed by Visioneer and a designated version of software provided with the scanner. Visioneer makes reasonable efforts to verify the accuracy of content and issue resolution in these technical articles but cannot guarantee any matter including accuracy or results. The articles are provided "as is", without representation or warranty, express or implied, whether of merchantability, fitness for particular purpose, title, or non-infringement. Visioneer disclaims any liability for damages, whether direct or indirect, special, incidental, or consequential, from use of the information in these articles. Visioneer does not evaluate any effect on software and hardware not provided by Visioneer, and therefore disclaims any liability for same. Visioneer is not responsible for the content of support pages accessed through external links. The articles are subject to revision or change without notice.