Visioneer Knowledgebase
Visioneer Knowledgebase
Title: Updating Your Scanner Driver
Article ID:VIS1493
Updated:5/29/2014
Operating Systems:Please check below for driver compatibility
Scanner Models: Visioneer:
Flatbed: 9520, 9420, 7400, 7300, 9320, 9220, 9120, 9020, 9000, 8920, 8900, 8820, 8800, 8700, 8600, 8100, 7710, 7700, 7600, 7100, 6600, 6400u, 6200, 6100, 6000, 5820, 5800, 5600, 5300, 4800u, 4500, 4400, 3300, 3100, 3000, OneTouch, 2400p, 2400u, 2600u, 6136, 6142
ADF: XP470, XP450, PT430, PT470, 9750, 9650, 9650i, 9450, 8650, PT680, PT780
Strobe: 400, 500, XP300, XP220, XP200, XP100, RoadWarrior (RW120, PRW120)
Mobility
 Xerox:
X7600, X6400, DM250, DM250L, DM252, DM262, DM262i, DM272, DM150, DM152, DM162, DM510, DM515, DM520, DM632, DM700, DM752, DM3115, DM3220, DM4440, DM5445, DM5460, DM4830, DM4790, DM4799, DM4700, XMS
 

Purpose:

This article will guide you through the process of updating your scanner's driver to the most current version.
 

Symptom:

You are experiencing touble with your scanner, such as:
  • Unexpected scan results
  • Error messages when connecting the scanner
  • Error messages when scanning
 

Cause:

Unexpected results and error messages can be caused by corrupt, damaged, or duplicate driver files. We are constantly working to improve our drivers and software. In most cases the trouble that you are experiencing can be resolved by updating to the latest version of the scanner's driver.
 

Before you begin:

Please have all the required files available on your computer when you begin these instructions. We recommend downloading the following to your Windows desktop, or to your downloads folder. Do NOT run these until prompted by the instructions.

    Very Important:

    Before downloading, verify that your scanner's driver is supported by your computer's operating system.

  1. Please download your scanner's most current driver from:
  2. Please also save the following utility:
  3. Disable any AntiVirus, AntiSpyware, Firewall, PopUp Blocker, Spam Blocker, or Weather Bug software program from running.
    • If any of these applications are running, their icons will be in the Windows Notification area on the lower-right side of the computer next to the Windows System Clock.
  4. If you would like, you may print these instructions by clicking here.
 

Solution:

Step I - Uninstall the current scanner driver

  1. Turn off or diconnect your scanner.
  2. Open the Windows Control Panel.
  3. Open "Add/Remove Programs" or "Programs and Features".
  4. If listed, remove the Scanner driver.
    1. Scroll down the list and click on your existing scanner driver; the driver name will appear as OneTouch 2.0/3.0/4.0 and/or as your scanner model (i.e. Visioneer Scanner, Xerox DocuMate 510, etc.)
    2. Click on the "Change" or "Remove" button
    3. Follow the uninstall wizard through an automatic full uninstall (removal).
  5. Close the Add/Remove Programs and the Control Panel.

Step II - Use the Utility to cleanup the driver removal

  1. Run Hidden Devices+ as an Administrator by right-clicking on theutility and select "Run as Administrator".
    • In Windows XP you will not have this option. You must be logged on as an Administrator.
    • RunAsAdministratorRunAsAdministrator
      RunAsAdministrator
  2. The Windows Device Manager will open.
  3. Go to the "View" menu and select "Show Hidden Devices".
  4. Expand Imaging Devices to show all scanners and cameras previously and currently connected to the computer.
  5. Right-click on the Visioneer or Xerox scanner name and select "Uninstall".
  6. In the Confirm Device Uninstall window click on "Delete the driver software for this device" then click on "OK".
    • Repeat steps 5 and 6 for all instances of your scanner .
  7. IF you see ?OtherDevices, expand it.
  8. Right click and "Uninstall" any of the following:
    • USB Scanner
    • USB Device
    • Unknown Device
    • 1200 DPI Scanner
    • {Scanner Model}
    • (any other scanners or cameras listed here that you no longer use)
  9. Close the Device Manager, and return to your Windows Desktop.
Note: If you receive an error: "Failed to uninstall the device. The device may be required to boot up the computer", click here for instructions on uninstalling that device.
Note: If you receive an error: "Failed to uninstall the device. The device may be required to boot up the computer", search the KnowledgeBase for VIS1062. This article has instructions on uninstalling that device.

Step III - Install the latest driver for your scanner

  1. Double Click to run the scanner's driver installer that you downloaded.
  2. Follow the prompts through installing the scanner driver.
  3. STOP when you get to the "Finish / Connect the Scanner" screen.
  4. Connect and power on your scanner.
  5. Wait for the system to detect the scanner (this may take 30 seconds), then click on the "OK" button.
 

Resources:

Driver Downloads

Utilities

Related Articles

 

 

Visioneer Disclaimer


Visioneer provides these technical articles for information use only. The information is generally for a specific scanner model distributed by Visioneer and a designated version of software provided with the scanner. Visioneer makes reasonable efforts to verify the accuracy of content and issue resolution in these technical articles but cannot guarantee any matter including accuracy or results. The articles are provided "as is", without representation or warranty, express or implied, whether of merchantability, fitness for particular purpose, title, or non-infringement. Visioneer disclaims any liability for damages, whether direct or indirect, special, incidental, or consequential, from use of the information in these articles. Visioneer does not evaluate any effect on software and hardware not provided by Visioneer, and therefore disclaims any liability for same. Visioneer is not responsible for the content of support pages accessed through external links. The articles are subject to revision or change without notice.