Visioneer Knowledgebase
Visioneer Knowledgebase
Title: Administrator Rights Issues
Article ID: VIS1160
Updated: 8/31/2005
Operating Systems: Windows 7 / Vista / XP / 2000
Scanner Models: Visioneer Flatbed: 9420, 9320, 9220, 9120, 9020, 9000, 8920, 8900, 8820, 8800, 8700, 8600, 8200, 8100, 7100, 7400, 7300, 7710, 7700, 7600, 5820, 5800, 5600, 4500, 4400
  Visioneer Strobe: XP300, XP220, XP200, XP100, RoadWarrior (RW120, PRW120), StrobePro, PaperPort Strobe
  Visioneer ADF: PT480, XP470, XP450, PT430, S500 , PT680, PT780, 9750, 9650, 9450, 8650
  Xerox : X6400, X7600, X4800, X2400DM250, DM250L, DM252, DM262, DM262i, DM272, DM150, DM152, DM162, DM510, DM515, DM520, DM632, DM3640, DM752
 
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Symptom:
 
Scanner performs and functions normally under Administrator profile, but under any other user profile you are unable to access certain parts of the driver or scanner and/or software does not respond or work at all. You are getting an error message stating "You do not have permission to make the correct system modifications" or "Cannot start service, verify you have sufficient privledges to start system services."
 
Cause:
 
This is because of the restrictive permissions inherited within the Windows Operating System and not an issue with the software that came with the scanner The administrator on the local machine does not have any restrictions and has full access to all files and folders on the local PC. Users with more restrictive permissions (i.e. Power Users, Users, Guests) have less access to files and folders on the PC and may or may not have access to necessary files to operate the scanner and/or software.
 
Solution:
 
Note: Some of the information in this article is OneTouch version specific. If you are not sure whether you have OneTouch 3.0 or OneTouch 4.0, click here and select "Run" to find out.
Note: Some of the information in this article is specific to your version of OneTouch. If you are not sure whether you have OneTouch 3.0 or OneTouch 4.0, type http://support.visioneer.com/utilities/version-check.exe into the address bar of your browser window and hit "Enter" on your keyboard. Click "Run" when prompted.


Option 1 - Upgrade your driver

If you are using a OneTouch 3.0 driver you should check if a OneTouch 4.0 driver is available for your scanner as it may resolve the problem. To check for a OneTouch 4.0 driver, use the links below to access your products download page.
  • Visioneer United States: Once on the support page, select your Product Family. Then select your scanner model and click on "Drivers and Manuals".
  • Visioneer Europe: Once on the support page, select your Product Family, then select your scanner model, then click on "Drivers and Manuals".
  • Xerox United States: Once on the support page select your scanner model.
  • Xerox Europe: Once on the support page, select your scanner product family then product.
  • Visioneer United States: Once on the support page, select your Product Family. Then select your scanner model and click on "Drivers and Manuals".
  • Visioneer Europe: Once on the support page, select your Product Family, then select your scanner model, then click on "Drivers and Manuals".
  • Xerox United States: Once on the support page select your scanner model.
  • Xerox Europe: Once on the support page, select your scanner product family then product.

Option 2 - Make the user an administrator

Add the user to the "Local Administrators" group in the user accounts on the local PC.

Option 3 - Give user permission to specific folders and registry keys

If you do not want to make the user an administrator, you can give the user full read/write permission to the folders and registry keys listed below.

For more information on accessing the registry and setting permissions, click VIS1176 - Navigating the Windows Registry. For more information on changing folder or registry permissions, click VIS1432 - Changing Registry and Folder Permissions.

For more information on accessing the registry and setting permissions, search the Knowledgebase for VIS1176. For more information on changing folder or registry permissions, search the Knowledge base for VIS1432.


Windows Vista

All scanner models
  • Registry Keys
    • HKEY_LOCAL_MACHINE\Software\Scansoft
    • HKEY_LOCAL_MACHINE\Software\Visioneer
    • HKEY_CURRENT_USER\Software\Scansoft
    • HKEY_CURRENT_USER\Software\Visioneer
  • Folders
    • C:\Program Files\Scansoft
    • C:\Program Files\Visioneer
    • C:\Windows\Twain_32
Sheetfed scanners (XP300, XP220, XP200, XP100, RoadWarrior)
  • Folders
    • C:\ProgramData\Visioneer
Windows XP

All scanner models
  • Registry Keys
    • HKEY_LOCAL_MACHINE\Software\Scansoft
    • HKEY_LOCAL_MACHINE\Software\Visioneer
    • HKEY_CURRENT_USER\Software\Scansoft
    • HKEY_CURRENT_USER\Software\Visioneer
    • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB
    • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class
  • Folders
    • C:\Program Files\Scansoft
    • C:\Program Files\Visioneer
    • C:\Windows\Twain_32
Sheetfed scanners using OneTouch 4.0 (XP300, XP220, XP200, XP100, RoadWarrior)
  • Folders
    • C:\Documents and Settings\All Users\Application Data\Visioneer
XP200 using OneTouch 3.0
  • Folders
    • C:\Windows\System32\stbxp200
DocuMate 510 using OneTouch 3.0
  • Folders
    • C:\DM510
    • C:\Program Files\Xerox\DM510
Windows 2000

All scanner models
  • Registry Keys
    • HKey Local_Machine on Local Machine
      • Software\Scansoft
      • Software\Visioneer
      • System\CurrentControlSet\Enum\USB
      • System\CurrentControlSet\Control\Class
    • HKey Current_User on Local Machine
      • Software\Scansoft
      • Software\Visioneer
  • Folders
    • C:\Program Files\Scansoft
    • C:\Program Files\Visioneer
    • C:\Winnt\Twain_32
Sheetfed scanners using OneTouch 4.0 (XP300, XP220, XP200, XP100, RoadWarrior)
  • Folders
    • C:\Documents and Settings\All Users\Application Data\Visioneer
XP200 using OneTouch 3.0
  • Folders
    • C:\Winnt\System32\stbxp200
DocuMate 510 using OneTouch 3.0
  • Folders
    • C:\DM510
    • C:\Program Files\Xerox\DM510
 
Library:
 
VIS1166 - Kofax Administrator Rights Issues

 

Visioneer Disclaimer


Visioneer provides these technical articles for information use only. The information is generally for a specific scanner model distributed by Visioneer and a designated version of software provided with the scanner. Visioneer makes reasonable efforts to verify the accuracy of content and issue resolution in these technical articles but cannot guarantee any matter including accuracy or results. The articles are provided "as is", without representation or warranty, express or implied, whether of merchantability, fitness for particular purpose, title, or non-infringement. Visioneer disclaims any liability for damages, whether direct or indirect, special, incidental, or consequential, from use of the information in these articles. Visioneer does not evaluate any effect on software and hardware not provided by Visioneer, and therefore disclaims any liability for same. Visioneer is not responsible for the content of support pages accessed through external links. The articles are subject to revision or change without notice.